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Introduction to BIRT
(Business Intelligence Reporting Tools)

A handout for the ERP system course at Aalborg University

(This introduction document is mainly based on the report by Leon Torres and Si Chen, but is adapted to the Aalborg
University Students’ needs, such as using the embedded database Derby, integration of reports into OFBiz, etc. For
the original document see http://www.opensourcestrategies.com/ofbiz/ofbiz-birt.pdf)

Installation and first steps
The Business Intelligence Reporting Tools (BIRT) is a suite of tools for generating professional-looking re-

ports from a database. BIRT can be integrated into a web application server framework to render reports
in HTML or PDF on the fly. Alternatively, BIRT can run standalone using the Rich Client Platform (RCP)
Designer application, which is installed on a client machine and connects to an OFBiz database remotely.

This tutorial describes in detail how to set up the BIRT RCP Designer application on a Windows machine
and how to connect to the embedded database Derby of OFBiz. It also presents a brief tutorial on how to
generate reports using sample students and their progress in our studentProgress application from last
week.

The database used in this tutorial is Derby 10.2.1.6. However, it is easy to use any other database with the
appropriate drivers.

Prerequisites

You will need the standalone BIRT RCP Designer, see http://download.eclipse.org/birt/downloads/. It
comes either with the entire Eclipse SDK and all necessary plug-ins, or just with the BIRT plug-ins (you will
need Eclipse SDK 3.3, EMF 2.3, DTP 1.5, and WTP 2.0). It will be easier to use the All-in-one package and
adapt it to your needs.

Next, you will need to download the JDBC driver for your database onto the Windows client machine so
that BIRT can connect. The Derby 10.2.1.6 JDBC driver is already distributed with OFBiz at the following
location: ofbiz/framework/entity/lib/jdbc/derby-10.2.1.6.jar. In order to avoid problems, copy this jar file
over the derby.jar file located in the Eclipse/plugins/org.apache.derby.core_ folder. Otherwise the BIRT
RCP Designer will use a driver not suited for the version of the OFBiz Derby database.

A better useable database viewer might be Quantum DB (http://quantum.sourceforge.net/), which is also
an Eclipse plug-in and helps a lot with testing SQL statements before creating a report. You can download
the Quantum DB plug-in at Sourceforge.

Running BIRT
Start Eclipse and create your first BIRT report project by selecting File > New > Other... > Folder “Business
Intelligent and Reporting Tool” > Report Project. Second, create a new BIRT report (either via context
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menu or File menu), name it like myFirstReport.rptdesign and choose to switch to the Report Design
perspective. New views such as Palet, Data, and Property Editor open. In the middle is a view window
where you will construct the report by dragging and dropping elements from the Palet view.

Let's begin by constructing a title for the report. Drag a Label object from the Palet onto the view window.
You'll be prompted to enter the label text. Type in the title of the first report and press Enter. To change
the text again, double click on the label.

Underneath the view is a Property Editor which displays options for the Label. You can change the font,
colors, and general appearance. Make the Label looks like a title by changing the background color, in-
creasing the font size, centering the text and making it bold.

Now add a text object underneath the title to describe the first report. To do this, drag a Text from the
Palet and a box should pop up prompting for input. Enter a description such as, “This is a report that
shows the sales breakdown by product.” The text should appear as the illustration above.

Connecting to the database

Databases are represented as Data Sources in BIRT. Find the Data Explorer tab next to the Palet and click
on it. You should see a Data Sources folder. To create a Data Source, right click on the Data Sources folder
and select New Data Source.

You'll be prompted to select a Data Source type. Select JDBC Data Source and click on Next.

The next dialog requests the connection information. First we will need to add our JDBC driver to the list
named Driver Class. To do this, select Manage Drivers.

& Manage JDBC Drivers §|
IAR Files | Drivers |
Criver Class Mame Cisplay Mame  URL Template
orgd.eclipse birt report. data.oda.sampledb . Ori...  Classic Mode...  jdbc:classic...
org.apache.derby. jdbc. EmbeddedCriver Apache Der...  jdbciderby:...
@ Ok, ] I Cancel
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In the Manage JDBC Drivers dialog, use the Add button to add the JDBC jar file which you copied over to
this machine. It will show up in the list of JAR Files.

Once the driver is listed, click OK to return to the dialog asking for connection information.

Now you can select your driver from the Driver Class list. The remaining connection information should be
the same as that described in your OFBiz entityengine.xml configuration file. Enter the information and
then click on Test Connection to see if you can connect. Then click OK to return to the main view.

If an error message occurs, several problems may have occurred: either you use the wrong driver for your

embedded Derby database, or the database is already used by another instance (Derby databases only
accept one connection!).

 Edit Data Source - Data Source

IRT

T IDBC DA
Corin

ection Profile
Property BINndind | oyjver Class: | org.apache. derby jdbe EmbeddedDriver (Apache Derby Embedded Driver)

Edit the selected data source

Database URL: | jdbc:derby :d\opentapsiopentapsruntimetdatatderbyofbiz

Lzar Mame: | ofbiz
Fassword, | I
INDIURL: |

[Manage Crrivers... ] ITest Connecton...

2) 8] 4 } [ Cancel

Creating Report Queries
Assuming the connection was successful, we can proceed to define queries that our report will use. These
queries are called Data Sets. They are located in the Data Explorer under the Data Sources.

To create a new Data Set, right click on the Data Set folder and select New Data Set from the context
menu. This dialog asks for basic information about the Data Set. Give it a name, such as “Students and
their progress”. There is only one data source. The Data Set Type is SQL Select Query.

The next dialog allows you to construct a SQL query and navigate the database and all of its objects, in-
cluding tables, sequences, foreign keys, etc. (there might be some problems with the data table preview-
er, so that only the first n tables are shown). For testing your SQL queries better use the Quantum DB
Eclipse plug-in as mentioned above.
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£ Edit Data Set - StudentsProgress ‘:|®

Data Source Query o
OLiery

Output Columns Pvailable Iems: 1select firstiname, last name, myiprogress.myisubjectiid
Computed Columns = [ Data Source 2from my_student inner join my_progress

Parameters 3 OFEIZ 3on my_student.my student_id = my_progress.my_student_id

Filters

Froperty Binding
Settings

Preview ResLits

Schema; |—AH— - |

Filter: | |

Type: |—AH— w ‘ IAJJpIy Filter]

[ Use identifier quoting

Go ahead and type the query as shown in the illustration above. Alternatively, you can drag the names of
the objects from the tree onto the query to save some typing. The query could be more sophisticated, but
this is sufficient for the purpose of the tutorial.

= Edit Data Set - StudentsProgress

Data Source Output Columns o
Query

Define output colurmns:

Mame Type Alias Display Mame | Display Mame Key Edit...
FIRST_MAME  String
LAST _MNAME String
Property Binding MY_SUBJEC.. Sfring
Settings
Preview Results

Computed Columns
Farameters
Filters

|

v
-
w

6] [ OK ” Cancel ]

When you're finished, the Data Set should look like the illustration above. Notice that the result columns
are part of the list. This is important because we can drag these columns onto objects in the view to
create an association between a view object and the result column.

Presenting the Data Set in a Table

The next step is to display the results in a table. Go to the Palet and drag a Table object onto the view.
You will be presented with a dialog requesting the number of columns and details. There are three result
columns, so the default of three should be fine. Details is where our data would be displayed. Think of
Details as a union of Data Sets. Since there is only one Data Set, the default of one detail is good.

The table appears on the view showing three kinds of rows, a Header row for the column title, a Detalil
row for our data, and a Footer row.
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In order to link the table columns with the result set columns, all you need to do is drag the desired col-
umn from our Data Set in the Data Explorer onto the cell in the Detail row where you want the data to
display. BIRT fills in the Header for you.

£ Report Design - BirtProject/secondReport.rptdesign - Eclipse SDK

File Edit Insert Element Data Page Mavigate Search Project Run Window Help
(i @@ - F @D I : [ |2 Report De... | 7
5 Palette | 8 Data Explorer &2 - = 0 secondReportrptdesign 52X MyStudentScreens xml [E) main.f =8
(g Data Sources
=@ Data Sats

P Sales By Product .

& StudentsProgress -

({3 Report Parameters

(@ Data Cubes . |

: Students Progress
Students an their progress:
~ last name first name subject ID
% Navigator 32 B Outine =5 . [LAST_NAME] [FIRST_NAME] [MY_SUBJECT_ID]
ISP T N R
|2 main.fi Al - v
standard.css | Layout Master Page Script XML Source Preview

& widget [ Property Editor - Data Set 52 =l Properties =0

(¥ MyStudentScreens.xml A 5
) buildxml ropertes
¥ ofbiz-component.xml General General
warshatise Event Handler
companentdoad xml Mame: | studermsProgress |
README. bt bvmed Dista Source | Data Source |
sources D
Jtime
=cialpurpose 3
< I3
Domd

To format the table, click on each object to be formatted and edit their properties as you did with the
Label and Text objects. You can format individual cells or whole rows and columns. Finally, our report is
finished. Preview the results by clicking on the Preview tab, which is located along the bottom of the view.

& BIRT Report Viewer - Mozilla Firefox

Datel  Bearbeiten Ansicht  Chronik  Lesezeichen Exftras  Hife

e > @ ﬁ} r5:= - ||_| htq:u:,ff127.0.0.1:55555fvwewer,frum?_re\|'| [}l -[E'|5palte

H‘] E-a-

[#] My Student-Frogress Applicati... | | [} BIRT Report Viewer a| 7

Students Progress

tudents an their progress:

Last name first name subject 1D
Friis Morten [ DAT |
Friis Morten I PRO |
Friis Morten I SYS |
Schwarz Klemens \ DAT |
Schwarz Klemens ‘ ERP |
Schwarz Klemens I PRO |
Schwarz Klemens I SYS |

17.09.2007 0147

& suchen: link 3 Abwirts @ Aufwdrts [ Hervorheben [ Grof-Keinschreibung
o [yer @ %) @ Jetzt: Klare Macht, 11° C Mo: 22°C | Dit 220 C <o | M 15°C w7 | Do: 139 C <m| Fr: 1]
Saving the Report

To save the report, select Save from the File menu. This preserves all the work you've done up to this
point as a .rptdesign file and allows you to resume the report creation at a later time. The .rptdesign file is
also used to generate a report to the user dynamically as will be described in the next section.
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Presenting the Report Dynamically within OFBiz

Once you've saved your report as an .rptdesign file, you can use the report as HTML or PDF by using a web
browser. In Preview mode, right click on the window and select Create Shortcut from the context menu.

BIRT will place a URL shortcut on your desktop that contains the .rptdesign file.

The .rptdesign files that you create can be incorporated into an OFBiz by just creating an a-href link on a
FTL file or a XML screen file, either with the HTML or PDF result by choosing _ format=html or
__format=pdf as a parameter. The report will be updated every time the link is refreshed. As long as the

BIRT RCP Designer is running, your .rptdesign report will be rendered. You may have seen, that the re-

ports are always available from different ports everytime you start the BIRT Report Designer (so the gen-

erated links are always different). To avoid this, just go to Window > Preferences > Report Design > Pre-

view > Preview Server, leave the IP address empty, but choose a random port, where the reports should
be available, e.g. 55555 (see next figure).

- Preferences

type filter text

Eeneral
ANt
Connectvity
Help
Instal pdate
Internet
Java
Flug-in Development
Cuantum D
=-Report Design
Chart
Comment Templa
Crosstab
Drata Set Editor
Blement Mames
= Prevview
Preyie
Resource
Template
Run/Debug
Server
Team
Walidation

Preview Server e

Internal Application Server configuration. The server is used internally by
BIRT Feport Designer Praview Framework,

Host name or IP address of local machine. Leave blank, to be automaticaly

determined.

Fort for the server to listen on. Set to O, for dynamically assigned,
55555

Mote: If the server is aready running, these preferences wil only take effect
after restarting.

[Restore Qefaults” Apply ]

[ Ok H Cancel ]
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Integrating the report into your application
You can integrate the link to your report either in Freemarker files (*.ftl) or Screen files (YourApplication-
Screens.xml).

Integration into Main.ftl:

<h1>HELLO</h1>

<h37Hye - this 1is your first ofbiz application, the Student-Progress application</h3>
<p />

<a href="http://127.0.0.1:55555/viewer/run?__report=C:\secondReport.rptdesign&
__format=pdf&__svg=false&_ _locale=de_AT& _designer=true&__masterpage=true&
__rtl=false&__maxrows=500&_ _resourceFolder=C:\BirtProject&1440341526"

target= "_blank">Bericht</a>

Intagration into MyStudentScreens.xml:

<1link target="http://www.google.at" text="Link to extern website (example)" url-
mode="raw" style="buttontext" />

For a correct report appearance within a multi-user environment you will need to install the Derby Server
Framework instead of the embedded Derby database. See the Derby administration documentation site

for further details.

Conclusions

In this tutorial you learned how to set up BIRT RCP Designer on a client machine, how to connect BIRT to
the Derby embedded database, how to generate a report, and how to present the report as HTML or PDF
dynamically. | hope you will not have big problems with the setup and usage of BIRT created HTML/PDF

documents.
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